Microsoft Partner Center: Subscriptions stuck in "Pending"

Incident Report for Cloud Factory A/S

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 08:52 CET

Investigating

Microsoft is currently reporting issues with updates & provisioning of Subscriptions, resulting in a longer period of time where the subscription has a "Pending" status.

They are aware, and are looking into the issues.

We will update here as when we get more information.

Partners with access to the Partner Center can also follow along directly at Microsoft:
https://learn.microsoft.com/en-us/partner-center/support/view-partner-center-service-health
Posted Feb 19, 2025 - 12:05 CET
This incident affected: Partner Portal (Subscription Management, Mine Licenser).