We are currently experiencing technical difficulties with Dropbox

Incident Report for Cloud Factory A/S

Resolved

Dear partner

We are pleased to let you know that the problem has been resolved and we are up and running again.

We apologize for the challenges this may have caused!

Best regards
Cloud Factory team
Posted Sep 12, 2025 - 10:33 CEST

Investigating

Dear partner

We are currently experiencing technical difficulties with Dropbox

The issue is being investigated and we will post an update as soon as possible.

Best regards
Cloud Factory team
Posted Sep 12, 2025 - 09:26 CEST
This incident affected: Partner Portal (Subscription Management, Mine Licenser).