Microsoft's provisioning response times have returned to normal. License provisioning and change requests are now completing as expected. The incident is resolved.
Posted Jun 02, 2026 - 09:59 CEST
Monitoring
We have identified the cause: Microsoft is currently taking longer than usual to process license provisioning and change requests on their side. In nearly all cases, the requests are being processed correctly — they simply take longer to complete. Some users may receive a timeout error in the meantime; this does not mean the request has failed. We will continue to monitor and post an update as Microsoft response times normalize.
Posted Jun 01, 2026 - 19:35 CEST
Update
We are currently experiencing long handling times from Microsoft regarding license provisioning and changes. License provisioning requests may remain in pending status for an extended period.
Posted Jun 01, 2026 - 12:26 CEST
Investigating
Dear partner
We are currently experiencing technical difficulties with Microsoft license provisioning. .
The issue is being investigated and we will post an update asap.
Best regards Cloud Factory team
Posted Jun 01, 2026 - 12:23 CEST
This incident affected: Partner Portal (Subscription Management).